Office 365 (Outlook Web): Cannot Send Email to Contacts
Incident Report for cedarcrestcollege
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 09:46 EDT
Monitoring
Current status: Our system data analysis has focused our investigation to a group of recent service updates and has identified a service change which we believe has introduced the problem. As we work to confirm that we've isolated the source for this event, we're internally testing if reverting the service update successfully remediates the impact.
Posted May 24, 2023 - 08:52 EDT
Investigating
We have been notified that some users may be unable to send emails to recipients within their contact list using Outlook on the web.

When affected users select a contact list as the recipient from ‘My Contacts', the following error message appears, and the email cannot be sent: ‘This message can't be sent right now. Please try again later’.

Current status: We're continuing to analyze Outlook on the web server logs to isolate the root cause and establish a fix.
Posted May 23, 2023 - 08:31 EDT
This incident affected: Office 365 Services.