AstraSchedule: Currently offline
Incident Report for cedarcrestcollege
Resolved
Astra Schedule is not back online. We have not received any additional information from Ad Astra regarding the outage.
Posted Apr 27, 2023 - 09:04 EDT
Investigating
We have opened a ticket with Ad Astra support to have them investigate.
Posted Apr 27, 2023 - 08:24 EDT
This incident affected: Astra Schedule.