Office 365 (Outlook): Microsoft Outlook Mail Retrieval
Incident Report for cedarcrestcollege
Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 09:36 EST
Investigating
Microsoft is currently experiencing an issue that may prevent some individuals from seeing and accessing email from the Outlook desktop application. It seems that the web and mobile versions of Outlook are not impacted by this. If we receive more information, we will share it with the community.
Posted Jan 26, 2024 - 08:59 EST
This incident affected: Office 365 Services.