Office 365 (Email): Some outbound messages delayed or failing
Incident Report for cedarcrestcollege
Resolved
Microsoft has communicated that we are not using a third-party product that would cause this issue at this time, and should not be impacted any longer.
Posted Mar 14, 2024 - 08:58 EDT
Identified
Microsoft has identified the issue and is applying a fix.
Posted Mar 13, 2024 - 15:07 EDT
Investigating
Microsoft reports that some outbound emails are being delayed by several hours or failing altogether. They are estimating an impact of as much as 1%.

They are investigating the issue.
Posted Mar 13, 2024 - 14:38 EDT
This incident affected: Office 365 Services.