Office 365 (Microsoft Teams): Delays creating and editing calendar events via Teams Calendar
Incident Report for cedarcrestcollege
Resolved
Microsoft is no longer reporting this as an issue.
Posted Jun 16, 2023 - 09:39 EDT
Identified
Users may experience delays when attempting to create, cancel or modify Microsoft Teams calendar events. Microsoft has identified an issue, and is working on remediating that issue.
Posted Jun 15, 2023 - 09:30 EDT
This incident affected: Office 365 Services.