Office 365: Web Apps may be unable to view or access web apps in Microsoft 365 for some users
Incident Report for cedarcrestcollege
Resolved
Microsoft appears to have resolved the issue.
Posted Apr 20, 2023 - 16:50 EDT
Investigating
More info: Users may also be unable to access Microsoft 365 web apps through Microsoft Planner. Additionally, users may be unable to access the Microsoft Teams admin center.

Current status: Analysis of diagnostic data has identified an unusually high number of timeout exceptions within our caching and Azure Active Directory (AAD) infrastructure. We’re working to isolate the cause of these exceptions whilst identifying steps to remediate impact.

Scope of impact: Impact is specific to some users who were served through the affected infrastructure attempting to view or access web apps in Microsoft 365.
Posted Apr 20, 2023 - 10:27 EDT
This incident affected: Office 365 Services.