Office 365 (Outlook): Some emails are receiving NDR (Non-Delivery Reports) when sending
Incident Report for cedarcrestcollege
Resolved
MS reports this is not impacting our region.
Posted Jan 25, 2024 - 10:23 EST
Investigating
Microsoft is reporting an issue with emails not sending properly from Office 365 - this is not across every user. They are investigating.
Posted Jan 25, 2024 - 08:44 EST
This incident affected: Office 365 Services.