Office 365: Outlook Web Access Unable to Display Some Mailboxes
Incident Report for cedarcrestcollege
Resolved
Microsoft as marked this issue as resolved. Outlook web is functioning as expected this morning.
Posted Jun 28, 2023 - 08:55 EDT
Monitoring
Current status: Our initial testing has so far been successful and we're completing some final validation steps to ensure the fix fully addresses the issue. We'll provide an estimated time to resolve as soon as one becomes available.
Posted Jun 27, 2023 - 13:59 EDT
Identified
Some users in North America may be unable to access their Exchange Online mailbox using Outlook on the web

User impact: Users in North America may be unable to access their Exchange Online mailbox using Outlook on the web.

More info: Affected users may encounter an unexpected 500 error when accessing Outlook on the web.

Current status: We've determined that a recent system update to the Exchange Online service may have caused impact. This update has now been stopped, while we review diagnostic logs to explore mitigation options for the components that have already received this update.

Scope of impact: Impact is specific to some users in North America who are attempting to access their Exchange Online mailbox using Outlook on the web.
Posted Jun 27, 2023 - 09:24 EDT
This incident affected: Office 365 Services.